ATTENTION: TLS 1.2 Security Deadline Update – Please Review Immediately!

Last updated on March 22nd, 2018 at 02:52 pm CT

March 15, 2018 – Update

ATTENTION – TLS 1.2 Security Deadline Update
Please Review Immediately!

Experian Health has extended the TLS 1.2 Requirement Deadlines.
Due to PCI Compliance Requirements, Clients who use our Financial Products
(PaymentSafe, Patient Self Service)  Must Have TLS 1.2 Enabled by
Monday, April 30, 2018 to Prevent Service Disruption.

Clients who use our Non-Financial Products must complete their upgrades by June 30, 2018 

In the event your location cannot meet these deadlines, please immediately reach out to us at customer.support@experianhealth.com so that we can audit the progress of your upgrade.

Download – TLS 1.2 Document
FAQs, Readiness Checklist, Compatibility, and Product Testing

In addition to TLS 1.2 enabled Internet Browsers, Ecare NEXT (Click-Once, MSI, IPS), IntelliSource, and Medical Necessity clients must upgrade their applications!  Instructions for testing can be found by downloading the TLS 1.2 Document.

  • If you have Financial Products –
    Your Deadline is April 30th to upgrade your Internet Browser and NextBar/PIC.
  • If you don’t have Financial Products –
    Your Deadline is June 30th to upgrade Internet Browser and NextBar/PIC.

Product Specific Actions Required
eCare Next and IntelliSource
Ecare NEXT (Click-Once, MSI, IPS) or IntelliSource clients must upgrade their applications! Instructions for testing can be downloaded in the TLS document (above).

Medical Necessity
Click Here for the requirements and instructions to upgrade Medical Necessity Thin Client.
This is only for clients who use the Legacy Order Checker application (a/k/a Healthworks and IntelliSource Medical Necessity). This update does not apply to clients running Order Checker within the eCare Next platform.


Soon Approaching – TLS 1.2 Security Deadlines
Again, we want to remind you about our ongoing TLS 1.2 project and to ensure you are aware that this initiative requires your immediate attention.  Experian Health is focused on helping our customers improve their security by using the latest security protocols. At Experian Health, we take the protection of our customer’s data very seriously.

(Previous Posts - References)
Originally Posted: March 1, 2018 - Attention:  TLS 1.2 Security Deadline, April 2, 2018 – Take Immediate Action 
Originally Posted: Feb. 21, 2018 - Attention:  Immediate Action Required – TLS 1.2 Security Deadline – April 2, 2018
Originally Posted: Feb 15, 2018 - Initiation of TLS 1.2 Browser Notification Message - Thursday, February 15, 2018  
Originally Posted: Jan. 19, 2018 - Attention: Immediate Action Required – TLS 1.2 Security Deadline – April 2, 2018
Originally Posted: Sept. 02, 2017 - Immediate Action Required – TLS 1.2 Security Requirements Deadline –  April 2, 2018  

The disablement of TLS 1.0 and TLS 1.1 is being undertaken so we can maintain the highest security standards and promote the safety of your data as well as align with industry-wide best practices. This phased approach will prevent older encryption protocols from being used to access Experian Health services within inbound and outbound connections.