Now In-Process – TLS 1.2 Security, All Experian Health’s Financial Products

Last updated on May 13th, 2018 at 10:20 am CT

Now In Process – TLS 1.2 Security, All Experian Health’s Financial Products
Immediate Action Required – PCI Compliance and TLS 1.2 Security
In the event your location has not been able to meet the previous deadlines, please immediately reach out to us at customer.support@experianhealth.com so that we can audit the progress of your required upgrades.

 All Experian Health’s Financial Products – TLS 1.2 Security Deadline
Due to PCI Compliance and TLS 1.2 Security Requirements, clients or end users who process payments using any of our Financial Products (PaymentSafe, Link2Gov or L2G, Concord/First Data, Patient Self-Service, Cash Tracking) must complete the following actions.  In consideration of the efforts being made by our clients to achieve compliance, please be advised of the following:

  • Internet browsers must be TLS1.2 compliant.
  • Whitelisting of Domains and IPs need to be Added or Updated.
  • NextBar and PIC updates must be updated by June 30, 2018

Inform and communicate with your IT Staff and/or Network Administrators, to ensure that each of the following URLs and IP addresses are included and/or added in your Network Configuration and “Whitelisted” for any of your network proxy servers and firewalls.  To avoid any service disruptions in the near future, and/or end-user access, please complete these actions.

URL/Domain – paymentsafe.experianhealth.com
Whitelist IP Range – 199.96.232.175/199.96.233.175

URL/Domain – collections.ecarenext.com
Whitelist IP Range – 199.96.232.176/199.96.233.176

Non-Financial Products by June 30, 2018
Clients who use our Non-Financial Products, must complete their upgrades by: June 30, 2018

  • Browsers must be TLS1.2 compliant by 6/30
  • NextBar and PIC updates must be updated by 6/30

Download – TLS 1.2 Readiness Document
Includes Instructions, Checklist, FAQs, Compatibility, and Product Testing


Product Specific Actions Required for TLS 1.2 Deadlines

eCare NEXT Bar and IntelliSource (PIC)
In addition to enabled TLS 1.2 Internet Browsers, eCare NEXT (Click-Once, MSI, IPS), IntelliSource, and Medical Necessity clients must upgrade their applications. Instructions for enabling and testing TLS 1.2 can be downloaded in our TLS 1.2 Readiness Document, that provides Checklist, FAQs, Compatibility, and Product Testing.

  • If you have Financial Products –
    Please immediately upgrade your Internet browser and NextBar/PIC.
  • If you don’t have Financial Products –
    Your Deadline is June 30, 2018 to Upgrade Your Browser and NextBar/PIC.

Medical Necessity
Use this link to download the TLS 1.2 requirements and upgrade instructions for the
Medical Necessity – Thin Client.  This is only for clients who use the Legacy Order Checker application (a/k/a Healthworks and IntelliSource Medical Necessity). This update does not apply to clients who use Order Checker within their eCare NEXT platform.

 

 


 

[Previously post of 05.04.2018]

NOTICE – All Experian Health’s Financial Products
TLS 1.2 Security Deadline, Today,
Friday, May 4, 2018 at 8:00a.m. CT

Immediate Action Required – PCI Compliance and TLS 1.2 Security Deadlines, Tomorrow
In the event your location cannot meet these deadlines, please immediately reach out to us at customer.support@experianhealth.com so that we can audit the progress of your required upgrades.

All Experian Health’s Financial Products – TLS 1.2 Security Deadline
Due to PCI Compliance and TLS 1.2 Security Requirements, clients or end users who process payments using any of our Financial Products (PaymentSafe, Link2Gov or L2G, Concord/First Data, Patient Self-Service, Cash Tracking) must complete the following action.  In consideration of the efforts being made by our clients to achieve compliance, please be advised of the following:

  • Browsers must be TLS1.2 compliant by 8:00a.m. CT, May 4, 2018.
  • Whitelisting of Domains and IPs need to be Added or Updated by 8:00a.m. CT, May 4, 2018.
  • NextBar and PIC updates must be updated by June 30, 2018

Inform and communicate with your IT Staff and/or Network Administrators, to ensure that each of the following URLs and IP addresses are included and/or added in your Network Configuration and “Whitelisted” for any of your network proxy servers and firewalls. To avoid any service disruption and/or end-user access, please complete this action prior to 8:00a.m. CT, Friday, May 4, 2018.

URL/Domain – paymentsafe.experianhealth.com
Whitelist IP Range – 199.96.232.175/199.96.233.175

URL/Domain – collections.ecarenext.com
Whitelist IP Range – 199.96.232.176/199.96.233.176

Non-Financial Products by June 30, 2018
Clients who use our Non-Financial Products, must complete their upgrades by: June 30, 2018

  • Browsers must be TLS1.2 compliant by 6/30
  • NextBar and PIC updates must be updated by 6/30

Download – TLS 1.2 Readiness Document
Includes Instructions, Checklist, FAQs, Compatibility, and Product Testing


Product Specific Actions Required for TLS 1.2 Deadlines

Care NEXT Bar and IntelliSource (PIC)
In addition to enabled TLS 1.2 Internet Browsers, eCare NEXT (Click-Once, MSI, IPS), IntelliSource, and Medical Necessity clients must upgrade their applications. Instructions for enabling and testing TLS 1.2 can be downloaded in our TLS 1.2 Readiness Document, that provides Checklist, FAQs, Compatibility, and Product Testing.

  • If you have Financial Products –
    Your Deadline is 8:00a.m. CT May 4, 2018 to Upgrade Your Browser and NextBar/PIC.
  • If you don’t have Financial Products –
    Your Deadline is June 30, 2018 to Upgrade Your Browser and NextBar/PIC.

Medical Necessity
Use this link to download the TLS 1.2 requirements and upgrade instructions for the
Medical Necessity – Thin Client.  This is only for clients who use the Legacy Order Checker application (a/k/a Healthworks and IntelliSource Medical Necessity). This update does not apply to clients who use Order Checker within their eCare NEXT platform.


[Previously Posted]

Soon Approaching – TLS 1.2 Security Deadlines
Again, we want to remind you about our ongoing TLS 1.2 project and to ensure you are aware that this initiative requires your immediate attention.  Experian Health is focused on helping our customers improve their security by using the latest security protocols. At Experian Health, we take the protection of our customer’s data very seriously.

(Previous Posts - References)
Originally Posted: March 1, 2018 - Attention:  TLS 1.2 Security Deadline, April 2, 2018 – Take Immediate Action 
Originally Posted: Feb. 21, 2018 - Attention:  Immediate Action Required – TLS 1.2 Security Deadline – April 2, 2018
Originally Posted: Feb 15, 2018 - Initiation of TLS 1.2 Browser Notification Message - Thursday, February 15, 2018  
Originally Posted: Jan. 19, 2018 - Attention: Immediate Action Required – TLS 1.2 Security Deadline – April 2, 2018
Originally Posted: Sept. 02, 2017 - Immediate Action Required – TLS 1.2 Security Requirements Deadline –  April 2, 2018